Terje Sandstrom

------ Visual Studio ALM MVP ----- (also see new blog at http://hermit.no)

  Home  |   Contact  |   Syndication    |   Login
  64 Posts | 1 Stories | 116 Comments | 0 Trackbacks

News

Subscribe

Delicious Save this on Delicious Visual Studio Feeds

¨

Tag Cloud


Article Categories

Archives

Post Categories

Image Galleries

Company stuff

Interesting bloggers

Interesting companies

Microsoft

Microsoft Norge

Microsoft Regional Directors

Microsoft Test

MSFT Blogs

MVP

NNUG

Other interesting stuff

TFS

Visual Studio

This issue has popped up for some after having upgraded from Team System Beta 2 to RC.  You have remembered to uninstall everything (as Jakob points out here: http://geekswithblogs.net/jakob/archive/2010/02/09/reember-to-uninstall-all-beta-2-stuff-before-upgrading-to.aspx but you still get the following error box:

tfs1

saying Could not load type 'Microsoft.TeamFoundation.Client.TeamFoundationServerBase' from assembly 'Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.

At the same time, you see Power Tools functions are still there in Visual Studio, but no Power Tool appears in the Add/Remove programs.  This is some freak happening when uninstalling the beta Power Tools.

The solution, as first suggested and tried by Mathias Olausson, is to simply install the beta 2 Power Tools again, and uninstall them again. That seems to solve the problem.

posted on Wednesday, February 10, 2010 11:50 AM

Feedback

# re: How to fix annoying connection error to TFS server 2010 RC 2/23/2010 4:50 AM Gian Maria
Yes, it happened to me too. :)

Alk.

Post A Comment
Title:
Name:
Email:
Comment:
Verification: