Geeks With Blogs
Managed|Core Rai Umair's views on life, .net and software development all loosely coupled into one strongly typed weblog.

.NET Framework 1.1 saw a slight change for the web services, now the HTTP get is now not included in default in fact you have to override the default settings to use the Get behavior of the Webservice as was possible with framework 1.0.

All you have to do is add this entry to the Web.Config file in the same directory or above.

Add this code to your Web.Config file (this is case-sensitive):

<webServices>
 <protocols>
  <add name="HttpGet" />
 </protocols>
</webServices>

I found this annoying change of settings about eight months back but working on a new pair of Webservices for a new project I was surprised to find the problem again and this time I am writing in on my blog as to remembering it better.

Posted on Saturday, March 13, 2004 8:42 PM .NET | Back to top


Comments on this post: WebServices HTTP Get in .NET 1.1 - Now not included in default.

# re: WebServices HTTP Get in .NET 1.1 - Now not included in default.
Requesting Gravatar...
Cool post...I ran across this just today after my web host upgraded one of my accounts for ASP.NET v1.1.
Left by Jason Salas on Apr 07, 2004 9:36 AM

# re: WebServices HTTP Get in .NET 1.1 - Now not included in default.
Requesting Gravatar...
Thanks! I've been wondering how to do http get for some time now.
Left by *** on Nov 01, 2004 6:07 PM

# re: WebServices HTTP Get in .NET 1.1 - Now not included in default.
Requesting Gravatar...
Yo are the best, 10x man, you save me
Left by Katmai81 on Feb 01, 2005 1:40 PM

# re: WebServices HTTP Get in .NET 1.1 - Now not included in default.
Requesting Gravatar...
Great snippet of information!
Left by cp on Feb 19, 2005 12:16 AM

Your comment:
 (will show your gravatar)


Copyright © Rai Umair | Powered by: GeeksWithBlogs.net