Geeks With Blogs

News

eXTReMe Tracker


Head Explodes Too much information

For my first blog entry I'd like to mention something that seems to be left out of  the many Biztalk tutorials and examples out on the web.  Let me start by saying how much this little quirk drove me nuts and how much time I wasted trying to figure out why this strange behavior was happening.  I was ready to throw my face into a brick wall a few times.  So... its really simple, here goes:

Symptoms:
In HAT, under Orchestration debugger, your current Orchestration shows up just like you would expect.  As you look through the tracked events you might think Biztalk is jumping around or skipping your shapes.  This is the part where you go crazy.

Why does this happen?
For one very simple reason.  The Biztalk Host Application caches the orchestrations for optimization.  So while you might see your most recent orchestration in HAT, its actually running through an older version.  For me, this happened even if I re-deployed, re-GAC'd, re-binded, re-enlisted, re-started, re-gurgitated... wait...

Solution:
RESTART THE BIZTALK HOST APPLICATION!!!!!  Yes, that's it.  So stupidly simple.

Posted on Tuesday, September 13, 2005 12:25 PM Biztalk | Back to top


Comments on this post: Good to know...

# re:
Requesting Gravatar...
Sounds wicked. Thanks - your site is awesome. Come to my and find bmw m3 2002 for you!
Left by Vika on Feb 12, 2006 9:25 PM

Your comment:
 (will show your gravatar)


Copyright © Solid | Powered by: GeeksWithBlogs.net